• If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
Xin chào ! Nếu đây là lần đầu tiên bạn đến với diễn đàn, xin vui lòng danh ra một phút bấm vào đây để đăng kí và tham gia thảo luận cùng VnPro.

Announcement

Collapse
No announcement yet.

Lab 1-2: CẤU HÌNH IP UNNUMBERED

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lab 1-2: CẤU HÌNH IP UNNUMBERED

    Lab 1-2: CẤU HÌNH IP UNNUMBERED

    Trên router Cisco, mỗi cổng giao tiếp nối tới một phân đoạn mạng phải thuộc một subnet riêng biệt. Các router kết nối trực tiếp với nhau sẽ có các cổng giao tiếp được gán địa chỉ IP trong cùng một subnet. Nếu một router cần phải gởi dữ liệu tới mạng không nối trực tiếp, nó xem bảng định tuyến và chuyển tiếp gói tới trạm kế tiếp (next-hop) hướng tới đích. Nếu không có route trong bảng định tuyến, router chuyển tiếp gói tới địa chỉ router mặc định.

    Mỗi kết nối điểm-điểm (point-to-point) chỉ cần 2 địa chỉ, để tiết kiệm không gian địa chỉ có thể mượn địa chỉ IP của 1 cổng giao tiếp LAN để làm địa chỉ nguồn (source address) cho các thông tin cập nhật định tuyến (routing update).


    ¤ Các giao thức định tuyến khác nhau sẽ có cách hoạt động khác nhau đối với unnumber interfaces. Ví dụ: OSPF sẽ hoạt động nếu cả hai peers đều cấu hình unnumbered. Trong trường hợp chỉ 1 routers là unnumbered, quan hệ láng giềng của OSPF sẽ không được thiết lập. Các giao thức định tuyến khác như ISIS, EIGRP, BGP sẽ có những cách thức cư xử khác nhau đối với các cổng unnumbered. Điểm bất lợi duy nhất của unnumbered interface là ta không có khả năng kiểm tra (testing và management). Ngoài ra, unnumbered chỉ hoạt động trên kết nối point-to-point.


    Các ví dụ sau xem xét cấu hình IP unnumbered với các trường hợp địa chỉ IP khác nhau ở cổng Ethernet.

    Trường hợp 1: Các subnet có cùng major network kết nối qua cổng serial



    R0
    !
    hostname R0
    !
    ip subnet-zero
    !
    interface Serial0/0
    ip unnumbered Ethernet1/0
    !
    interface Ethernet1/0
    ip address 172.16.10.196 255.255.255.192
    !
    router igrp 10
    network 172.16.0.0
    !
    ip classless
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    !
    end

    R1
    !
    hostname R1
    !
    ip subnet-zero
    !
    interface Ethernet0
    ip address 172.16.1.1 255.255.255.192
    !
    interface Serial1
    ip unnumbered Ethernet0
    clockrate 64000
    !
    router igrp 10
    network 172.16.0.0
    ip classless
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    !
    end

    Kiểm tra

    R0#sh ip ro
    Gateway of last resort is not set
    172.16.0.0/26 is subnetted, 3 subnets
    C 172.16.10.192 is directly connected, Ethernet1/0
    I 172.16.0.0 [100/80225] via 172.16.1.1, 00:00:39, Serial0/0
    I 172.16.1.0 [100/80225] via 172.16.1.1, 00:00:39, Serial0/0

    R0#ping 172.16.1.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/56 ms

    R1#sh ip route
    Gateway of last resort is not set
    172.16.0.0/26 is subnetted, 3 subnets
    I 172.16.10.192 [100/8576] via 172.16.10.196, 00:00:00, Serial1
    I 172.16.0.0 [100/8576] via 172.16.10.196, 00:00:00, Serial1
    C 172.16.1.0 is directly connected, Ethernet0

    R1#ping 172.16.10.196
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.10.196, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms


    Trường hợp 2: Các major network khác nhau kết nối qua cổng serial có cùng subnet mask



    R0
    !
    interface Ethernet1/0
    ip address 170.16.10.196 255.255.0.0
    no keepalive
    !
    interface Serial0/0
    ip unnumbered Ethernet1/0
    !
    router igrp 10
    network 170.16.0.0


    R1
    !
    interface Ethernet0
    ip address 172.16.1.1 255.255.0.0
    no keepalive
    !
    interface Serial1
    ip unnumbered Ethernet0
    clockrate 64000
    !
    router igrp 10
    network 172.16.0.0


    R0#sh ip ro
    Gateway of last resort is not set
    C 170.16.0.0/16 is directly connected, Ethernet1/0
    I 172.16.0.0/16 [100/80225] via 172.16.1.1, 00:00:35, Serial0/0

    R0# ping 172.16.1.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

    R1#sh ip ro
    Gateway of last resort is not set
    I 170.16.0.0/16 [100/8576] via 170.16.10.196, 00:00:27, Serial1
    C 172.16.0.0/16 is directly connected, Ethernet0

    R1#ping 170.16.10.196
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 170.16.10.196, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms


    Trường hợp 3: Các subnet với subnet mask khác nhau, các major mạng khác nhau




    R0
    !
    interface Serial0/0
    ip unnumbered Ethernet1/0
    !
    interface Ethernet1/0
    ip address 170.16.10.196 255.255.255.192
    no keepalive
    !
    router igrp 10
    network 170.16.0.0
    !

    R1
    !
    interface Ethernet0
    ip address 172.16.1.1 255.255.0.0
    no keepalive
    !
    interface Serial1
    ip unnumbered Ethernet0
    clockrate 64000
    !
    router igrp 10
    network 172.16.0.0
    !


    R0#sh ip ro
    Gateway of last resort is not set
    170.16.0.0/26 is subnetted, 1 subnets
    C 170.16.10.192 is directly connected, Ethernet1/0
    I 172.16.0.0/16 [100/80225] via 172.16.1.1, 00:00:22, Serial0/0


    R1#show ip route
    Gateway of last resort is not set
    170.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    I 170.16.10.192/32 [100/8576] via 170.16.10.196, 00:00:35, Serial1
    I 170.16.0.0/16 [100/8576] via 170.16.10.196, 00:00:35, Serial1
    C 172.16.0.0/16 is directly connected, Ethernet0

    R1#ping 170.16.10.196
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 170.16.10.196, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms


    Trường hợp 4: Các subnet cùng subnet mask thuộc các major network khác nhau




    R0
    !
    interface Serial0/0
    ip unnumbered Ethernet1/0
    !
    interface Ethernet1/0
    ip address 170.16.10.196 255.255.255.192
    !
    router igrp 10
    network 170.16.0.0
    !

    R1
    !
    interface Ethernet0
    ip address 172.16.1.1 255.255.255.192
    !
    interface Serial1
    ip unnumbered Ethernet0
    clockrate 64000
    !
    router igrp 10
    network 172.16.0.0
    !


    R1#sh ip ro
    Gateway of last resort is not set
    170.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    I 170.16.10.192/32 [100/8576] via 170.16.10.196, 00:00:01, Serial1
    I 170.16.0.0/16 [100/8576] via 170.16.10.196, 00:00:01, Serial1
    172.16.0.0/26 is subnetted, 1 subnets
    C 172.16.1.0 is directly connected, Ethernet0

    R0#sh ip rou
    Gateway of last resort is not set
    170.16.0.0/26 is subnetted, 1 subnets
    C 170.16.10.192 is directly connected, Ethernet1/0
    172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    I 172.16.0.0/16 [100/80225] via 172.16.1.1, 00:00:17, Serial0/0
    I 172.16.1.0/32 [100/80225] via 172.16.1.1, 00:00:17, Serial0/0

    R0#ping 172.16.1.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms
    Email : vnpro@vnpro.org
    ---------------------------------------------------------------------------------------------------------------
Trung Tâm Tin Học VnPro
149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
Tel : (08) 35124257 (5 lines)
Fax: (08) 35124314

Home page: http://www.vnpro.vn
Support Forum: http://www.vnpro.org
- Chuyên đào tạo quản trị mạng và hạ tầng Internet
- Phát hành sách chuyên môn
- Tư vấn và tuyển dụng nhân sự IT
- Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

Network channel: http://www.dancisco.com
Blog: http://www.vnpro.org/blog

  • #2
    xin Bác Admin giải thích rõ hơn vể hiện tượng cho các câu route trong các trường hợp khác nhau ở trên.
    Mình dùng IGRP làm routing protocol thì làm sao có nhiều câu route vậy?

    Comment


    • #3
      rất bổ ích ,tks nhiều
      [TD]japanese translation service in japan[/TD],[/TR]
      [TR],[TD]japanese translation company in japan[/TD],[TD]japanese translation agency in japan[/TD],english to japanese translation service company[/TD]

      Comment

      • Working...
        X