Announcement

Collapse
No announcement yet.

Lab 2-2: VLAN

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lab 2-2: VLAN

    Lab 2-2: VLAN



    Mô tả
    –Cấu hình trên switch Catalyst 2900 XL hỗ trợ 4 VLAN: Marketing, Accounting, Enginerring và Network Management theo bảng sau:

    VLANs VLAN 1: Network Management VLAN 10: Accounting VLAN 20: Marketing VLAN 30: Engineering
    Port Numbers Fa0/1 – Fa0/3 Fa0/4 – Fa0/6 Fa0/7 – Fa0/9 Fa0/10 – Fa0/12


    + Trong khi triển khai VLAN trong một hệ thống mạng cục bộ, người quản trị có thể thiết kế VLAN theo hai cách thức:

    * Thiết kế VLAN theo dạng end-to-end: còn gọi là campus-wide.
    Trong kiểu chia VLAN này, VLAN sẽ trải rộng trên toàn campus. Một thành viên của VLAN đó di chuyển trong mạng, thuộc tính là thành viên của VLAN đó không thay đổi. Điều này có nghĩa là, mỗi VLAN phải sẵn có ở từng switch, đặc biệt là những switch nằm ở layer access trong mô hình 3-layer: core-distribution-access.
    Như vậy, trong end-to-end VLAN, các người dùng sẽ được nhóm vào thành những nhóm dựa theo chức năng, theo nhóm dự án hoặc theo cách mà những người dùng đó sử dụng tài nguyên mạng.

    *Chia VLAN dạng cục bộ:
    VLAN được giới hạn trong một switch hoặc một khu vực địa lý hẹp (trong một wiring closet). L‎y do để dùng dạng VLAN này là các VLAN dạng end-to-end trở nên khó duy trì. Các người dùng thường xuyên yêu cầu nhiều tài nguyên khác nhau. Các tài nguyên này thường nằm trong nhìều VLAN khác nhau.


    Thực hiện

    1.Trước tiên phải tạo cơ sở dữ liệu VLAN. Mỗi VLAN có một số phân biệt là vlan-id, có thể từ 1 đến 1001. Để tạo cơ sở dữ liệu VLAN (VLAN database) thực hiện các bước như sau:

    –Vào mode cấu hình cho VLAN database:

    Switch#vlan database

    –Tạo mới VLAN bằng câu lệnh vlan vlan-id [name name]. Nếu không đặt tên cho VLAN thì tên sẽ được lấy mặc định

    Switch(vlan)# vlan 20 name marketing

    –Cập nhật dữ liệu VLAN vào cơ sở dữ liệu VLAN, và thoát về priviledge mode.

    Switch(vlan)# exit


    –Kiểm tra cấu hình VLAN bằng lệnh show vlan

    Switch# vlan database
    Switch(vlan)# vlan 20 name marketing
    VLAN 20 added:
    Name: marketing
    Switch(vlan)# exit
    APPLY completed.
    Exiting....


    Switch# show vlan name marketing
    VLAN Name Status Ports
    ---- -------------------------------- --------- ---------------------
    20 marketing active

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- ------ ------
    20 enet 100003 1500 - - - - 0 0


    Việc tạo ra các VLAN khác sẽ được thực hiện tương tự.

    2.Gán các port cho VLAN tương ứng.


    Trước tiên cần cấu hình tất cả các port là “access” ports. Các port trên switch 2900 có thể ở 1 trong 3 chế độ: trunk port, multi-VLAN port và access port. Trunk port và multi-VLAN port được dùng để nối với switch khác (hoặc thiết bị khác có tạo VLAN trunking). Do kết nối các workstation với các port này nên cần phải cấu hình tất cả các port này ở chế độ access port.

    Switch(config)#interface fa0/1
    Switch(config-if)#switchport mode access


    Gán các port vào VLAN theo yêu cầu bằng cách sử dụng lệnh switchport access vlan n (n là số hiệu VLAN)

    Switch(config)#interface fa0/4
    Switch(config-if)#switchport access vlan 10
    Switch(config)#interface fa0/5
    Switch(config-if)#switchport access vlan 10
    Switch(config)#interface fa0/6
    Switch(config-if)#switchport access vlan 10
    Switch(config)#interface fa0/7
    Switch(config-if)#switchport access vlan 20
    Switch(config)#interface fa0/8
    Switch(config-if)#switchport access vlan 20
    Switch(config)#interface fa0/9
    Switch(config-if)#switchport access vlan 20
    Switch(config)#interface fa0/10
    Switch(config-if)#switchport access vlan 30
    Switch(config)#interface fa0/11
    Switch(config-if)#switchport access vlan 30
    Switch(config)#interface fa0/12
    Switch(config-if)#switchport access vlan 30


    Bạn không cần phải cấu hình port fa0/1-fa0/3 là VLAN 1 vì mặc định các port được gán vào VLAN 1.

    Ví dụ cấu hình gán port 07 cho VLAN 20 và kiểm tra lại cấu hình

    Switch# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)# interface fa0/7
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 20
    Switch(config-if)# end


    Switch# show interface fa0/7 switchport
    Name: Fa0/7
    Switchport: Enabled
    Administrative mode: static access

    Operational Mode: static access
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled

    Access Mode VLAN: 20 (marketing)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE


    3.Thực hiện kiểm tra các VLAN trên switch bằng lệnh show vlan

    Switch# show vlan brief
    VLAN Name Status Ports
    ---- -------------------------------- --------- ---------------------
    1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/13,
    Fa0/14, Fa0/15, Fa0/16
    10 Accounting active Fa0/4 – Fa0/6
    20 maketing active Fa0/7 – Fa0/9
    30 Engineering active Fa0/10 – Fa0/12
    40 VLAN0040 active
    1002 fddi-default active
    1003 token-ring-default active
    1004 fddinet-default active
    1005 trnet-default active
    Email : vnpro@vnpro.org
    ---------------------------------------------------------------------------------------------------------------
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel : (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Network channel: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog

  • #2
    rất đầy đủ thông tin cám ơn bác admin

    Comment


    • #3
      cho mình hỏi cái này với
      Mình cấu hình như sau:

      PC1 & 2,3,4---Switch1----Router1----Router2----Switch2---PC5&6

      Mình đã cấu hình đầy đủ, ở bất cứ thiết bị nào cũng đều Ping qua nhau được cả.

      Sau đó, mình tạo 2 VLAN ở Switch 2 và PC 5 thuộc 1 Vlan, PC 6 thuộc 1 Vlan khác, mình ko tạo Trunk

      Ping từ PC 5 qua 6 được và ngược lại. Nhưng Ping từ PC đến default gateway (IP của cổng Fa từ Router 2 nối với SW2 đó) lại ko dc
      Làm thế nào để khắc phục hả các bác?
      Last edited by hkien; 25-01-2008, 02:48 PM.

      Comment


      • #4
        Originally posted by hkien View Post
        cho mình hỏi cái này với
        Mình cấu hình như sau:

        PC1 & 2,3,4---Switch1----Router1----Router2----Switch2---PC5&6

        Mình đã cấu hình đầy đủ, ở bất cứ thiết bị nào cũng đều Ping qua nhau được cả.

        Sau đó, mình tạo 2 VLAN ở Switch 2 và PC 5 thuộc 1 Vlan, PC 6 thuộc 1 Vlan khác, mình ko tạo Trunk

        Ping từ PC 5 qua 6 được và ngược lại. Nhưng Ping từ PC đến default gateway (IP của cổng Fa từ Router 2 nối với SW2 đó) lại ko dc
        Làm thế nào để khắc phục hả các bác?

        Chào bạn , bạn cho mình biết thông tin chi tiết hơn được khôg như cấu hình hay địa chị Ip của các thiết bị .

        Chúc bạn vui !!!
        Trần Mỹ Phúc
        tranmyphuc@hotmail.com
        Hãy add nick để có thông tin đề thi mới nhất :tranmyphuc (Hỗ trợ tối đa cho các bạn tự học)

        Cisco Certs : CCNP (Passed TSHOOT 1000/1000)

        Juniper Certs :
        JNCIP-ENT & JNCIP-SEC
        INSTRUCTORS (No Fee) : CISCO (Professional) , JUNIPER (Professional) , Microsoft ...

        [version 4.0] Ôn tập CCNA


        Comment


        • #5
          cho mình hỏi VD mình có 03 VLAN và 03 đường Internet, thiết bị gồm có CoreSwitch 4506, Switch CE 500, và Router 3840. đường Internet nối vào Router. Cấu hình làm sao để VLAN 1 đi internet bằng ISP1, VLAN2 đi internet bằng ISP2, VLAN3 đi internet bằng ISP3 trong khi vẫn đảm bảo 03 VLAN thấy nhau.

          Comment


          • #6
            Originally posted by mhpit View Post
            cho mình hỏi VD mình có 03 VLAN và 03 đường Internet, thiết bị gồm có CoreSwitch 4506, Switch CE 500, và Router 3840. đường Internet nối vào Router. Cấu hình làm sao để VLAN 1 đi internet bằng ISP1, VLAN2 đi internet bằng ISP2, VLAN3 đi internet bằng ISP3 trong khi vẫn đảm bảo 03 VLAN thấy nhau.
            Gợi ý : bạn dùng access-list , kết hợp với việc apply lại in , out vào từng sub-interface trên router sẽ thành công. Thiết bị cần dùng là switch layer 2 và Router.

            Chúc bạn vui !!!
            Trần Mỹ Phúc
            tranmyphuc@hotmail.com
            Hãy add nick để có thông tin đề thi mới nhất :tranmyphuc (Hỗ trợ tối đa cho các bạn tự học)

            Cisco Certs : CCNP (Passed TSHOOT 1000/1000)

            Juniper Certs :
            JNCIP-ENT & JNCIP-SEC
            INSTRUCTORS (No Fee) : CISCO (Professional) , JUNIPER (Professional) , Microsoft ...

            [version 4.0] Ôn tập CCNA


            Comment


            • #7
              cho em hoi!!!Em dung dynamips de lam may bai LAB trong cuon LabPro co dc ko vay???Vi em ko co thiet bi that de lam

              Comment


              • #8
                sao em thay may bai Lab co bai thi (with file .NET) co bai thi ko vay???co fai bai nao co (with file .NET) thi moi lam bang dynamips dc ko?Trong sach LabPro cung vay ha~???

                Comment


                • #9
                  Chào !!!
                  Những bài LAB trích ra từ sách CCXX Labpro, đều được thực hiện trên thiết bị thật.
                  Những bài LAB chỉ liên quan đến ROuter bạn có thể thực hiện giả lập bằng dynamips
                  Những bài LAB liên quan đến Switch , sẽ có một số chức năng mà SWitch giả lập không có
                  Tham khảo tại :
                  http://www.vnpro.org/forum/showthread.php?t=15551

                  http://www.vnpro.org/forum/showthread.php?t=15499

                  chúc bạn vui !!!
                  Trần Mỹ Phúc
                  tranmyphuc@hotmail.com
                  Hãy add nick để có thông tin đề thi mới nhất :tranmyphuc (Hỗ trợ tối đa cho các bạn tự học)

                  Cisco Certs : CCNP (Passed TSHOOT 1000/1000)

                  Juniper Certs :
                  JNCIP-ENT & JNCIP-SEC
                  INSTRUCTORS (No Fee) : CISCO (Professional) , JUNIPER (Professional) , Microsoft ...

                  [version 4.0] Ôn tập CCNA


                  Comment


                  • #10
                    Originally posted by admin View Post
                    Lab 2-2: VLAN



                    Mô tả
                    –Cấu hình trên switch Catalyst 2900 XL hỗ trợ 4 VLAN: Marketing, Accounting, Enginerring và Network Management theo bảng sau:

                    VLANs VLAN 1: Network Management VLAN 10: Accounting VLAN 20: Marketing VLAN 30: Engineering
                    Port Numbers Fa0/1 – Fa0/3 Fa0/4 – Fa0/6 Fa0/7 – Fa0/9 Fa0/10 – Fa0/12


                    + Trong khi triển khai VLAN trong một hệ thống mạng cục bộ, người quản trị có thể thiết kế VLAN theo hai cách thức:

                    * Thiết kế VLAN theo dạng end-to-end: còn gọi là campus-wide.
                    Trong kiểu chia VLAN này, VLAN sẽ trải rộng trên toàn campus. Một thành viên của VLAN đó di chuyển trong mạng, thuộc tính là thành viên của VLAN đó không thay đổi. Điều này có nghĩa là, mỗi VLAN phải sẵn có ở từng switch, đặc biệt là những switch nằm ở layer access trong mô hình 3-layer: core-distribution-access.
                    Như vậy, trong end-to-end VLAN, các người dùng sẽ được nhóm vào thành những nhóm dựa theo chức năng, theo nhóm dự án hoặc theo cách mà những người dùng đó sử dụng tài nguyên mạng.

                    *Chia VLAN dạng cục bộ:
                    VLAN được giới hạn trong một switch hoặc một khu vực địa lý hẹp (trong một wiring closet). L‎y do để dùng dạng VLAN này là các VLAN dạng end-to-end trở nên khó duy trì. Các người dùng thường xuyên yêu cầu nhiều tài nguyên khác nhau. Các tài nguyên này thường nằm trong nhìều VLAN khác nhau.


                    Thực hiện

                    1.Trước tiên phải tạo cơ sở dữ liệu VLAN. Mỗi VLAN có một số phân biệt là vlan-id, có thể từ 1 đến 1001. Để tạo cơ sở dữ liệu VLAN (VLAN database) thực hiện các bước như sau:

                    –Vào mode cấu hình cho VLAN database:

                    Switch#vlan database

                    –Tạo mới VLAN bằng câu lệnh vlan vlan-id [name name]. Nếu không đặt tên cho VLAN thì tên sẽ được lấy mặc định

                    Switch(vlan)# vlan 20 name marketing

                    –Cập nhật dữ liệu VLAN vào cơ sở dữ liệu VLAN, và thoát về priviledge mode.

                    Switch(vlan)# exit


                    –Kiểm tra cấu hình VLAN bằng lệnh show vlan

                    Switch# vlan database
                    Switch(vlan)# vlan 20 name marketing
                    VLAN 20 added:
                    Name: marketing
                    Switch(vlan)# exit
                    APPLY completed.
                    Exiting....


                    Switch# show vlan name marketing
                    VLAN Name Status Ports
                    ---- -------------------------------- --------- ---------------------
                    20 marketing active

                    VLAN Type SAID MTU Parent RingNo BridgeNo Stp Trans1 Trans2
                    ---- ----- ---------- ----- ------ ------ -------- ---- ------ ------
                    20 enet 100003 1500 - - - - 0 0


                    Việc tạo ra các VLAN khác sẽ được thực hiện tương tự.

                    2.Gán các port cho VLAN tương ứng.


                    Trước tiên cần cấu hình tất cả các port là “access” ports. Các port trên switch 2900 có thể ở 1 trong 3 chế độ: trunk port, multi-VLAN port và access port. Trunk port và multi-VLAN port được dùng để nối với switch khác (hoặc thiết bị khác có tạo VLAN trunking). Do kết nối các workstation với các port này nên cần phải cấu hình tất cả các port này ở chế độ access port.

                    Switch(config)#interface fa0/1
                    Switch(config-if)#switchport mode access


                    Gán các port vào VLAN theo yêu cầu bằng cách sử dụng lệnh switchport access vlan n (n là số hiệu VLAN)

                    Switch(config)#interface fa0/4
                    Switch(config-if)#switchport access vlan 10
                    Switch(config)#interface fa0/5
                    Switch(config-if)#switchport access vlan 10
                    Switch(config)#interface fa0/6
                    Switch(config-if)#switchport access vlan 10
                    Switch(config)#interface fa0/7
                    Switch(config-if)#switchport access vlan 20
                    Switch(config)#interface fa0/8
                    Switch(config-if)#switchport access vlan 20
                    Switch(config)#interface fa0/9
                    Switch(config-if)#switchport access vlan 20
                    Switch(config)#interface fa0/10
                    Switch(config-if)#switchport access vlan 30
                    Switch(config)#interface fa0/11
                    Switch(config-if)#switchport access vlan 30
                    Switch(config)#interface fa0/12
                    Switch(config-if)#switchport access vlan 30


                    Bạn không cần phải cấu hình port fa0/1-fa0/3 là VLAN 1 vì mặc định các port được gán vào VLAN 1.

                    Ví dụ cấu hình gán port 07 cho VLAN 20 và kiểm tra lại cấu hình

                    Switch# configure terminal
                    Enter configuration commands, one per line. End with CNTL/Z.
                    Switch(config)# interface fa0/7
                    Switch(config-if)# switchport mode access
                    Switch(config-if)# switchport access vlan 20
                    Switch(config-if)# end


                    Switch# show interface fa0/7 switchport
                    Name: Fa0/7
                    Switchport: Enabled
                    Administrative mode: static access

                    Operational Mode: static access
                    Administrative Trunking Encapsulation: isl
                    Operational Trunking Encapsulation: isl
                    Negotiation of Trunking: Disabled

                    Access Mode VLAN: 20 (marketing)
                    Trunking Native Mode VLAN: 1 (default)
                    Trunking VLANs Enabled: NONE
                    Pruning VLANs Enabled: NONE


                    3.Thực hiện kiểm tra các VLAN trên switch bằng lệnh show vlan

                    Switch# show vlan brief
                    VLAN Name Status Ports
                    ---- -------------------------------- --------- ---------------------
                    1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/13,
                    Fa0/14, Fa0/15, Fa0/16
                    10 Accounting active Fa0/4 – Fa0/6
                    20 maketing active Fa0/7 – Fa0/9
                    30 Engineering active Fa0/10 – Fa0/12
                    40 VLAN0040 active
                    1002 fddi-default active
                    1003 token-ring-default active
                    1004 fddinet-default active
                    1005 trnet-default active
                    hic sao bac' hok dung` le^nh switch(config)#int range idint ?->? cho no' nhanh ma` phai gan' tug` cong?! gop' y vay thoi chu' thanks admin da~ gui? bai` lab

                    Comment


                    • #11
                      @mannk87: Mình nghĩ Switch 2900XL không hổ trợ lệnh như bạn góp ý

                      Comment


                      • #12
                        Switch(config)#interface range fa0/4 - fa0/6
                        Switch(config-if-range)#switchport access vlan 10
                        Switch(config-if-range)#interface range fa0/7 - fa0/9
                        Switch(config-if-range)#switchport access vlan 20
                        Switch(config-if-range)#interface range fa0/10 - fa0/12
                        Switch(config-if-range)#switchport access vlan 30

                        Mình cấu hình trên con SW 2950T-24
                        Switch(config-if-range)#
                        CCNA v5 | CCNA 5 | CCNA v5| CCNA v5 Blog

                        Comment


                        • #13
                          Bác Admin ơi, mình mới nghiên cứu Cisco nên cũng không thành thạo về Vlan lắm, thấy bác trình bày chu đáo mình muốn bác giúp cho chuyện này:
                          1. bác trình bày cho mình cách config switch (SW) catalyst 2950 có nối với 1 router (R) nào đó mà R có thêm 1 Ethernet nối với mạng ngoài. SW có vài VLAN và cấu hình sao cho các VLAN đều ra mạng ngoài được nhưng giữa các Vlan thì không thấy nhau
                          2. Điều quan trọng là làm sao để thiết lập đường trunking lên R, còn lệnh routing thì mình cũng đã thạo
                          3. Không biết giả lập các lệnh trên trên packet tracer 5 được không?

                          Comment


                          • #14
                            thanks! baj viet good quá
                            =============

                            Comment

                            Working...
                            X